Aide Excel - compter nombre d'occurence [Résolu]

A voir également:Compter le nombre d'occurence excelExcel compter le nombre d'occurence - Meilleures réponses Excel compter nombre occurence - Meilleures réponses Excel nombre d'occurences ✓ - Forum - Programmation Excel compter le nombre d'occurence dans une cellule ✓ - Forum - Excel Excel compter le nombre d'occurence ✓ - Forum - Excel Excel - Compter le nombre d'occurences d'un élément ✓ - Forum - Excel Compter le nombre d'occurence unique en fonction d'un critère ✓ - Forum - Excel

Bonjour,

j'aurais besoin d'aide, j'ai un petit souci en excel...

J'ai une fusion de colonne (B, C, D) sur la ligne 1, dans cette fusion, j'ai le mot Lundi (ainsi de suite pour les autres jours de la semaine).

Dans la ligne 2, en B2, j'ai TB. En C2, j'ai S. En D2, j'ai I. (la même chose pour les autres jours de la semaine).

Ensuite, en A3, j'ai Toto et en A4, j'ai Titi.

Je donne des côtes aux différentes personnes (mettre une croix dans la case correspondant à la côte. Par exemple, un TB le lundi pour Toto, un I le lundi pour Titi... )

Je voudrais compter le nombre différent de TB, S, I que chaque personne a eu sur la semaine.


En espérant avoir été assez clair.

Merci d'avance

Forum

A voir également:Compter le nombre d'occurence excelExcel compter le nombre d'occurence - Meilleures réponses Excel compter nombre occurence - Meilleures réponses Excel nombre d'occurences ✓ - Forum - Programmation Excel compter le nombre d'occurence dans une cellule ✓ - Forum - Excel Excel compter le nombre d'occurence ✓ - Forum - Excel Excel - Compter le nombre d'occurences d'un élément ✓ - Forum - Excel Compter le nombre d'occurence unique en fonction d'un critère ✓ - Forum - Excel

Web: www.shapebootstrap.net

10 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Il y a plus simple ^_^ : il suffit de mettre la commande suivante !

=NB.SI(A0:A8;"*BRA*")

les * permettent de remplacer n'importe quoi dans la chaine de caractère.

Dire « Merci » 82

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 70231 internautes nous ont dit merci ce mois-ci

Reply
réponses:
  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

source: "http://forum.hardware.fr/..."


>>> Mais si je veux compter le nombre de fois qu'apparait "BRA" dans un grand nombre de cellule, je suis plutot mal. En plus, il est possible que le texte que je cherche, ici "BRA" soit qu'un partie du contenu de la cellule. Typiquement, si dans une cellule, j'ai "BRA, GLE", je veux que ca me le compte. La par contre, je ne sais pas comment faire, surtout que la cellule peut aussi bien contenir differents mots qu'être vide.

Nabou
Mon p'tit bout d'chou...
Posté le 30-03-2006 à 13:40:09

Utilise la fonction NB.SI

benratti
Posté le 30-03-2006 à 15:01:09

Ok, je te remercie, ca fait a peut pret ce que je veux. J'ai donc la formule suivante :
=NB.SI(M2:M49;"BRA" )

Ca me permet bien de compter le nombre de cellule dont le contenu est "BRA". Par contre, je ne vois pas comment faire pour tester non pas que le contenu de la cellule soit egal, mais que le contenu contienne le mot que je recherche.


Nabou
Mon p'tit bout d'chou...
Posté le 30-03-2006 à 15:16:52

J'ai eu ce besoin il y a quelque temps et j'ai utilisé pour détecter une chaine quelconque la formule suivante : =SI(CHERCHE($D$2;B4);"OK";"" ) (tu mets ce que tu veux à la place de D$B$) en fait, sur chaques lignes, j'ajoute ce test et en fin de tableau sur la colonne de résultat j'utilise NB.SI pour compter le nb de résultat concluant, c'est un peu lourd mais ça fonctionne

Message édité par Nabou le 30-03-2006 à 15:24:01

Reply
réponses:
  • auteur

  • auteur

  • auteur

  • auteur

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Salut,

tu peux voir la fonction nb.si, qui compte le nombre de cellules d'une plage donnée qui ont une valeur donnée...
Ex :

=NB.SI(A1:A50,"TB")
--
A+ Blux
 "Les cons, ça ose tout.  C'est même à ça qu'on les reconnait"

Reply
réponses:
  • auteur

  • auteur

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Pour ma par ce qui a marché c'est =NB.SI(C2:C122;"oui"), si ça peut aider certains, va compter tous les oui pour la plage C2 à C122 ;)

Voili voilou

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Combien de fois trouve-t-on la lettre N (le contenu de A9) dans la cellule C2

=NBCAR(SUBSTITUE($C$2;$A9;"WW"))-NBCAR($C$2)

Le formule remplace les N par WW, et compte les caractères
Elle déduit le nb de caractères de la cellule à l'origine.
S'il y avait 23 caractères dont 5 N à l'origine, il y a 28 caractères dont 10 W à la fin.
La différence 28 - 23 = 5 donne le nb de N in dans la cellule d'origine.

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

bien que je n'est pas trouve de solution aucune de ces formules est correcte

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

salut,

une petite question :
j'ai créé un tableau avec deux feuilles,
dans le premier tableau une liste d'article avec une colonne "E" ou je veux mettre un "x"
pour qu'il me renvois la ligne dans le tableau de la deuxième feuille en A:B mais sans sauter de
ligne à chaque fois.
comment puis-je faire SVP
Merci de votre réponse

René

Reply
réponses:
  • auteur

  • auteur

  • auteur

  • auteur

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonsoir à tous,

J'aurais besoin d'aide pour un tableau de disponibilité.

Je m'explique
feuille N°1 :j'ai un tableau d'archivage ( fais sur Base d'une macro (composer comme tel: Numéro de facture en A1, Nom du client en B1, Prénom en C1 des période en D1 et en E1 le nom de la maison)

Feuille N° 2 : j'ai un tableau avec le titre de mes colonne c'est le nom de mes maison et le titre de mes ligne est les périodes.

J'aimerais que sur base de ma feuille d'archivage (période et Nom de maison) un croix se met dans mon tableau en feuille 2.
J'espère avoir était claire si pas dites moi.

je vous remercie d'avance de votre aide !!!

Reply
réponses:
  • auteur

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Je ne sais pas si vous avez lu la réponse que j'ai mis au dessus, mais elle doit être valable normalement sachant qu'elle prend en compte les chaînes de caractères.

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour;

A la place de la plage de recherche de NB.SI, je cherche à mettre un numéro de ligne définit sur une autre cellule.

Cordialement

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed