Faire la moyenne de pourcentage sur Excel [Résolu]

A voir également:Moyenne de pourcentageMoyenne de pourcentage excel - Meilleures réponses Moyenne pourcentage excel - Meilleures réponses Moyenne de pourcentage excel - Forum - Excel Moyenne de pourcentage d'évolution ✓ - Forum - Excel Moyenne pourcentage dans un tableau évolutif ✓ - Forum - Excel Moyenne pourcentage - Forum - Excel Calcul de pourcentage sur excel ✓ - Forum - Excel

Bonjour,

Je ne sais pas si le titre correspond complétement à ce que je recherche mais je n'ai pas su comment mieux le nommer.
Je travaille sur un fichier Excel avec (en gros) plusieurs fournisseurs, qui vont réaliser plusieurs prestations et toutes ces prestations on un taux de conformité différents.
Pour avoir le taux de conformité par prestation j'ai utilisé, une fonction "si" afin que selon les remarques ça me ramènent à un taux de conformité. (100% ; 75% ; 50% etc )

C'est maintenant que ça pêche, je ne trouve pas la solution pour faire maintenant la moyenne générale des prestations par fournisseurs.
J'ai essayé avec la fonction moyenne mais ça n'a rien donnée, mais je m'y prend surement mal. Et on ne peut pas dire que moi et les tableaux croisés dynamiques nous soyons les meilleurs amis du monde.

Il y a t-il une technique particulière quand le contenu des cellules n'est pas un chiffre mais la conséquence d'une formule?

Merci pour votre aide!

Cdt

Forum

A voir également:Moyenne de pourcentageMoyenne de pourcentage excel - Meilleures réponses Moyenne pourcentage excel - Meilleures réponses Moyenne de pourcentage excel - Forum - Excel Moyenne de pourcentage d'évolution ✓ - Forum - Excel Moyenne pourcentage dans un tableau évolutif ✓ - Forum - Excel Moyenne pourcentage - Forum - Excel Calcul de pourcentage sur excel ✓ - Forum - Excel

Web: www.shapebootstrap.net

1 réponse

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour
que le contenu d'une cellule soit un chiffre ou le résultat d'une formule, ça ne devrait pas in fluer sur le résultat, à condition que vous renvois à 100% ect... soit bien des valeurs numériques

en conséquence
MOYENNE.SI(champ fournisseur; fournisseur;champ %)
devrait fonctionner

Quelle est la formule placée dans les cellules %

à vous lire
crdlmnt

Dire « Merci » 2

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 55280 internautes nous ont dit merci ce mois-ci

Reply
réponses:
  • auteur

  • auteur

    Alors :
    1ere colonne : nom des fournisseurs (A)
    2eme colonne : conformité = "oui ou "non" (B)
    3eme colonne : détail de non conformité : soit "plan" soit "saisie" soit "plan+saisie" (C)
    4eme colonne : le détail (D)
    5eme colonne : le taux de conformité avec la formule : =SI(C15="PLAN+SAISIE";"50%";SI(C15="PLAN";"75%";SI(C15="SAISIE";"75%";100%)))
    6eme colonne : moyenne : ne marche donc pas . Avec l'exemple fournisseur xxx : (donc je filtre pour n'avoir que ce fournisseur) =MOYENNE(E30:E1823) (E30:E1823) étant l'ensemble des pourcentage qui ressortent des prestations en fonction du fournisseurs xxx

    J'espère que je suis claire..

    Merci pour ton aide
    Cdt

  • auteur

    Bonjour

    essaie
    =SI(C15="PLAN+SAISIE"=0,5;SI(C15="PLAN";0,75;SI(C15="SAISIE";0,75;1)))

    Bonjour Vaucluse, excuses l'incruste !
    :o)

  • auteur

    C'est sans problème Michel,en fait c'est un peu ce qu'on pouvait prévoir, des valeurs entre guillemets dans la formule qui renvoient des textes avec le signe % et pas des valeurs num.
    Peut être peut on préciser aussi que pour afficher tes % avec ta formule, il suffit de formater les cellules en "pourcentage"
    et aussi que la MOYENNE.SI ou MOYENNE.SI.ENS ne s'écrivent pas comme dans le message de Bouchon

    bien cordialement

    PS et donc que la formule devrait s'écrire, si on place un nom de fournisseur en F1 pour l'exemple:
    =MOYENNE.SI(A:A;F1;E:E)
    et si risque qu'il n'y ait pas de,fournisseur, pour faire propre:
    =SIERREUR(MOYENNE.SI(A:A;F1;E:E);"")

  • auteur

    Merci pour vos réponse! J'essaierai ces formules lundi et je vous tiendrai au courant des résultats! Encore merci pour votre aide!
    Cdt

  • auteur

    Ton erreur est celle indiquée par Vaucluse "des valeurs entre guillemets dans la formule qui renvoient des textes avec le signe % et pas des valeurs num"

  • auteur

    Bonjour,
    Merci beaucoup pour votre aide très précieuse! Et merci de m'avoir consacré un peu de votre temps! Tout fonctionne parfaitement grâce à vous!
    Merci encore!
    Cdt :)

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed