Liste déroulante pour sélectionner une feuille [Résolu]

A voir également:Liste déroulante pour sélectionner une feuilleCreer liste deroulante excel avec données autre feuille - Conseils pratiques - Excel Liste déroulante et protection feuilles excel ✓ - Forum - Excel Liste déroulante dans feuille protégée Excel ✓ - Forum - Excel Sélectionnez liste déroulante et afficher donnees ✓ - Forum - Access Copier, renommer feuille VBA + Liste déroulante ✓ - Forum - Excel

Bonjour,

Je réalise actuellement un fichier Excel afin de suivre le taux de rendement synthétique d'un site de production cependant je me heurte à un problème. Le site dispose de 4 presses qui ont chacune une feuille Excel identique seules les valeurs changes je souhaiterai donc que vous m'indiquiez comment créer une liste déroulante contenant les noms des feuilles et que ce choix modifie la page prise en compte dans les calcul exemple ci dessous.

Merci à l'avance.

=+SOMME.SI.ENS('PRESSE 1'!$M$4:$M$3000;'PRESSE 1'!$A$4:$A$3000;$B$12;'PRESSE 1'!$O$4:$O$3000;C28)

Forum

A voir également:Liste déroulante pour sélectionner une feuilleCreer liste deroulante excel avec données autre feuille - Conseils pratiques - Excel Liste déroulante et protection feuilles excel ✓ - Forum - Excel Liste déroulante dans feuille protégée Excel ✓ - Forum - Excel Sélectionnez liste déroulante et afficher donnees ✓ - Forum - Access Copier, renommer feuille VBA + Liste déroulante ✓ - Forum - Excel

Web: www.shapebootstrap.net

4 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Si la liste déroulante (validation de données) est en A1, avec une formule employant INDIRECT() :
=SOMME.SI.ENS(INDIRECT("'" & A1 & "'!$M$4:$M$3000");INDIRECT("'" & A1 & "'!$A$4:$A$3000");$B$12;INDIRECT("'" & A1 & "'!$O$4:$O$3000");C28) 


Cordialement
Patrice

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 47351 internautes nous ont dit merci ce mois-ci

Reply
réponses:
  • auteur

    Bonjour Patrice ,

    Je tenais tout d'abord à vous remercier pour votre réponse qui résout mon premier problème cependant malgré mes recherches je ne sais pas comment créer une liste déroulante permettant de sélectionner mes feuilles ('PRESSE 1'!)('PRESSE 3'!)('PRESSE 4'!)('PRESSE 5'!). Pourriez vous me l'expliquer ?

    Merci pour votre aide par avance.

  • auteur

    PS : Avec la formule précédente, la liste déroulante ne doit contenir ni apostrophe ni point d'exclamation soit, dans la case source :
    PRESSE 1;PRESSE 3;PRESSE 4;PRESSE 5

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour.
Plutôt qu'une liste déroulante, il serait beaucoup plus pratique et approprié d'insérer des liens hypertexte.

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 47351 internautes nous ont dit merci ce mois-ci

Reply
réponses:
  • auteur

    Bonjour Raymond

    Les liens ne conviendront pas : « comment créer une liste déroulante [...] et que ce choix modifie la page prise en compte dans les calcul ...»

    Cordialement
    Patrice

  • auteur

    Exact ...

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour ,

J'ai crée des liens hypertextes comme vous me l'avez conseillé cependant je n'arrive pas à faire fonctionner la formule j’obtiens une erreur #REF. Je vous joins une capture d'écran pour vous aider a comprendre le problème.
Merci d'avance pour votre aide !

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

j'ai enfin réussi à tout faire fonctionner grâce a vos conseils je vous remercie de m'avoir aidé tous les 2

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed