Code vba pour fonction conditionnelle multiple - Forum Excel

Code vba pour fonction conditionnelle multiple Code vba(somme et multiplication) » Forum - VB / VBA Code VBA selection conditionnelle » Forum - Excel Code vba pour arreter une macro (Résolu) » Forum - Bureautique VB6/.Net VBA Transformer chiffres en lettre » Conseils pratiques - Langages Où enregistrer le code vba excel 2010 » Forum - Excel

Bonjour,

je voudrai de l'aide pour automatiser mon travail par code vba en utilisant la fonction conditionnelle :
nous somme dans la feuille client :

colonne tonnage- colonne gasoil- colonne type- colonne primechauffeur

je veux remplir automatiquement dans la colonne type suivant colonne tonnage remplie manuellement :
import lourd 10t ( SI inférieur ou égal à 10t)
import lourd 20t (SI de 11t à 19t)
import lourd (SI superieur ou égale à 20t)

puis on cherche le primechauffeur suivant tonnage(rempli manuellement) - gas-oil (à remplir manuellement) et type(rempli par code vba ci-dessus)

par exemple : SI TYPE= import lourd 10t et GASOIL = 320 then
primechauffeur = 20000

comment écrire tous ça en code VBA

ma base de donnée a beaucoup de ligne parce qu'il y a de départ tous les jours (entreprise de transport)

merci

Forum

Code vba pour fonction conditionnelle multiple Code vba(somme et multiplication) » Forum - VB / VBA Code VBA selection conditionnelle » Forum - Excel Code vba pour arreter une macro (Résolu) » Forum - Bureautique VB6/.Net VBA Transformer chiffres en lettre » Conseils pratiques - Langages Où enregistrer le code vba excel 2010 » Forum - Excel

Web: www.shapebootstrap.net

2 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

comment écrire tous ça en code VBA
Pourquoi écrire du code que tu ne maitrise pas (si j'ai bien compris) alors que tu peux faire cela avec le fonctionnempent normal d'un tableur ?

je veux remplir automatiquement dans la colonne type

="import lourd"&SI(A2<10;" 10t";SI(A2<20;" 20t";""))


on cherche le prime chauffeur suivant tonnage
=SI(ET(A2<10;B2=320);10000;"")

Cette formule est simplifiée bien sûr mais je ne veux pas inventer ce que tu ne nous a pas dit ! ;-)

Reply
réponses:
  • Papasossy

    Merci beaucoup je vais essayer ça!

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed