Secure boot violation

Secure boot violation UEFI - Secure boot violation (Résolu) » Forum - BIOS Message "Secure Boot Violation" / Bouton de Secure Boot Grisé (Résolu) » Forum - BIOS Probleme Asus message secure boot violation » Forum - Windows Secure boot violation. invalid signature...... » Forum - Windows 8 / 8.1 Secure boot violation [Résolu] » Forum - Linux / Unix

Bonjour à tous,

Je viens d'acheter mon pc portable gamer :
MSI PC Portable GL62MVR 7RFX-1262XFR - 15,6'' FHD - RAM 8 Go - Core i7-7700 - Stockage 128Go SSD + 1To HDD - GTX 1060 6Go
Sans système d'exploitation. J'ai donc installé moi-même windows 10 64bits, ce qui fut un exploit vu mes compétences en informatique !
Bon maintenant je tente d'installer les pilotes avec le mode hors ligne de drivercloud - est-ce une bonne chose ?

Tout rentre dans l'ordre petit à petit, mais lorsque j'allume mon ordinateur, un message d'erreur apparaît :
Son nom "Secure boot violation", son contenu : "Invalid signature detected. Check secure boot policy in setup".
Avec une option : "OK", quand je tape sur la touche Entrée, il disparaît et windows 10 se lance normalement.

Je ne sais pas vraiment ce que ce message signifie, ni si c'est grave, si je dois régler ça avant d'installer mes pilotes, mais je me doute que ce n'est pas top. Donc si vous avez une solution pour régler cette erreur je vous serais reconnaissant !

J'ajoute les photos du bios.

Merci !


Forum

Secure boot violation UEFI - Secure boot violation (Résolu) » Forum - BIOS Message "Secure Boot Violation" / Bouton de Secure Boot Grisé (Résolu) » Forum - BIOS Probleme Asus message secure boot violation » Forum - Windows Secure boot violation. invalid signature...... » Forum - Windows 8 / 8.1 Secure boot violation [Résolu] » Forum - Linux / Unix

Web: www.shapebootstrap.net

21 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Salut,

Désactiver le Secure boot (démarrage sécurisé) doit permettre de démarrer sur la clé USB, voir ce lien : https://www.malekal.com/comment-desactiver-le-secure-boot/

Maintenant, le message n'est pas censé s'afficher si la clé USB est bien faites.
Je pense que tu as dû la formater en NTFS alors qu'il aurait fallu le faire en FAT32.
Tu as utilisé le Media Creation Tool ?
Si tu as utilisé Rufus, il faut choisir GPT et vérifier en bas que tu as FAT.
Voir ce lien pour les détails : https://www.malekal.com/comment-creer-une-cle-usb-dinstallation-de-windows/

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Merci pour ta réponse très rapide.

J'ai utilisé Rufus pour créer ma clé USB bootable, j'ai suivi pour ça un toturiel envoyé par le vendeur du fichier ISO (+ clé d'activation), voici le lien vers le tutoriel en question, partie Rufus :
https://forums.cnetfrance.fr/topic/1234837-windows-10--comment-creer-une-cle-usb-bootable-avec-l-iso-windows-10/

Qui n'indique pas les mêmes préconisations que toi.
J'ai bien mis ma clé en premier dans le BIOS (Boot) pour l'installer, j'ai rentré ma clé d'activation, etc. avant de remettre mon disque dur en première position afin d'avoir accès à windows 10 (d'ailleurs si vous avez un ordre idéal pour le reste je suis preneur)
Tu me conseille quoi maintenant ? De réinstaller windows 10 avec ces configurations Rufus ? J'ai peur que ma clé d'activation ne fonctionne plus.

Je précise bien que, contrairement à ce qui est dit dans ton tuto, ce message d'erreur s'affiche alors que je n'ai pas de clé branchée sur l'ordinateur et que si je fais "ok", windows 10 se lance normalement.

Reply
réponses:
  • auteur

  • Malekal_morte-

    Je t'ai donné un lien avec les indications et la marche à suivre, je vois pas l'intérêt d'aller sur un autre lien.

  • DocR

    D'accord je te fais confiance, mais donc tu confirme, il faut que je réinstalle windows 10 avec ces nouvelles caractéristiques : et surtout je pourrais à nouveau utiliser la même clé d'activation ?

  • Malekal_morte-

    Ces réglages n'ont rien à voir avec ta licence ou clé.
    Soit tu désactives le secure boot et tu devrais pouvoir démarrer sur la clé que j'ai fait.
    Soit tu refais ta clé comme je t'ai indiqué.

  • DocR

    Ok, je vais refaire la clé avec Media Creation Tool puisque ça a l'air conseillé. Je vois que c'est toi qui a écris ce tuto, merci beaucoup.

  • DocR

    J'ai re-créé ma clé grâce à Media Creation Tool cette fois. Je l'ai insérée dans le nouveau pc, j'ai mis le port usb en 1er dans le boot menu, j'ai pu installer à nouveau windows 10. J'ai ensuite remis mon disque dur en 1ère position dans le boot menu, sauvegardé et quitté, puis je tombe à nouveau sur le message "Secure boot violation"... Donc exactement pareil, quand je fais "ok" ça démarre sur windows.

    "Soit tu désactives le secure boot et tu devrais pouvoir démarrer sur la clé que j'ai fait."
    Je ne comprends pas bien. J'ai essayé de désactiver le secure boot, mais visiblement je n'y arrive pas. Tu peux voir la dernière photo de mon premier post. J'appuis sur la dernière option "secure boot" et j'arrive sur la 2ème photo, je mets désactive attempt secure boot et ça redémarre sur des lignes de codes... "Secure boot mode" est sur "standard", l'autre option c'est "custom" ; mais je ne sais que faire, je ne trouve pas de tuto avec les mêmes options.

    Sinon la phase post installation est différente, j'ai l'impression que ça a installé des pilotes : j'ai cortana qui me parle et qui me propose de me connecter à ma box etc. Mais bon, j'ai peur de devoir recommencer toutes ces longues étapes à cause de mon message d'erreur.

  • Malekal_morte-

    Qu'est ce que tu veux que je te réponde ?
    Je t'ai dit de créer une clé USB avec Rufus en GPT et formatée en FAT.
    Tu me sors un lien qui dit autre chose puis tu pars sur Media Creation Tool.

  • DocR

    Ce n'est pas ce que tu m'as dit, j'ai mal compris. Tu me demande si j'ai utilisé Media Creation Tool ou Rufus et dans le cas où j'utilise Rufus tu m'as indiqué quoi faire. Le lien que tu m'as donné indique que Rufus est plutôt destiné aux utilisateurs avancés, il oriente plutôt vers Media Creation Tool pour les noobs. Donc j'ai cru suivre tes conseils.

    Je recommence donc avec Rufus en GPT formatée en FAT32

  • DocR

    Et malheureusement ça ne change rien, toujours ce message d'erreur.

  • Malekal_morte-

    Sur cette page : https://img-19.ccm2.net/cbptnrtjQotrtwqdU2X4Eg-gUPM=/11cc5dc9455040dcbbbad486d47ca74d/ccm-ugc/SECURITY2.jpg
    Mets tout en disabled
    Quitte et enregistre et tente de démarrer sur la clé.

  • auteur

    J'ai mis tout ce que je pouvais dans cet onglet disabled. Une fois installé, je remets tout normal et je mets le disque dur en premier. Et même chose, le message d'erreur.

  • Malekal_morte-

    Comment ça le disque dur en premier ?
    C'est bien quand tu démarres sur la clé USB que tu as l'erreur Secure boot ?

  • auteur

    Non quand je démarre sur la clé ça affiche directement le menu d'installation de windows. Celui ci une fois terminé, demande à redémarrer, là je suis obligé de remettre le disque dur en premier sinon ça revient sur le menu d'installation de windows.
    Donc quand je redémarre sur le disque après installation je tombe sur le message d'erreur que je peux passer pour continuer avec windows.

  • Malekal_morte-

    haaaaaa d'accord, j'avais compris que c'était quand tu démarres sur la clé pas après avoir installé Windows.
    Il faut mettre Windows Boot Manager en premier et pas le disque dur.

  • DocR

    Voilà ce que je mets en premier :



    Tu me dis de ne pas mettre le disque dur en premier mais windows boot manager, or je lis "hard disk : windows boot manager...". Je comprends qu'il est dans le disque dur. De toutes façons c'est ça que je mets en premier depuis le début et ça affiche toujours le message d'erreur, j'aurais loupé quelque chose ?

    Je suis en train de me demander si j'ai installé sur la bonne partition. à mon avis oui "principal" et 921 Go si je me souviens bien.

  • Malekal_morte-

    Mets le quand même en premier, histoire d'être sûr que les autres ne posent pas de problèmes mêmes s'ils ne sont pas censés être utilisés.
    Essaye en remettant le BIOS par défaut.
    Pour l'installation, tu ne peux installer que sur des partitions principales, tu n'as pas vraiment le choix.
    A moins que tu aies deux partitions EFI sur un autre disque qui posent problème. Je vois pas trop.

    Normalement l'installation de Windows créé le démarrage de Windows avec les informations de sécurité qui vont bien pour que l'ordinateur reconnaissant que c'est un démarrage Windows et donc sécurisé.
    Le message n'a pas lieu d'être.

    Ce n'est pas non plus l'ISO vu que tu as fait plusieurs clés.

    Tu n'as qu'un seul disque dur ou plusieurs ?

    Tu peux donner une capture d'écran de la gestion des disques de Windows ?
    Pour voir les partitions de disques.

    et aussi :
    Touche Windows +R
    tape msinfo32.exe et OK.
    Donne une capture d'écran
    pour voir si une mise à jour du BIOS est dispo.

  • DocR

    Alors j'ai mis "restore defaults" dans l'onglet "save & exit" du bios et mis le "hard disk : windows..." en premier. Je remarque que dans l'onglet "boot" le "boot mode select" est remis sur [UEFI with CMS] (ou équivalent) donc au redémarrage je tombe sur des lignes de code. Je remets donc [UEFI] et redémarre, comme d'habitude je vois le message et je passe avant de taper ce que tu as demandé. Je joins les deux photos.

    Pour les disques dur, je pense que je n'en ai qu'un, voici la fiche du produit :
    [https://www.cdiscount.com/informatique/ordinateurs-pc-portables/msi-pc-portable-gl62mvr-7rfx-1262xfr-15-6-fhd/f-10709-9s716jbe21262.html




  • Malekal_morte-

    Les images sont illisibles surtout la première.
    Pourquoi tu prends des photos pour remettre en ligne ?
    Tu peux prendre des captures d'écran directement et de meilleur qualité sans appareil photo
    Regarde le lien que j'avais donné : https://www.commentcamarche.net/faq/398-comment-faire-une-capture-d-ecran

    Tu peux faire une capture d'écran de msinfo32.

    Installe Minitool partition Wizard : https://www.commentcamarche.net/download/telecharger-34078304-partition-wizard-home-edition
    Donne une capture d'écran des partitions
    Sur la partition de disque EFI (voir la colonne type)
    clic droite et explore
    Déroule le dossier EFI
    donne une capture d'écran

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Salut,

Ton PC est livré avec Freedos. Tu l'as (j'imagine) probablement écrasé en installant W10. La question qui se pose est la suivante : ne resterait-il pas des traces de freedos dans la partition efi (si tu ne l'as pas formatée) ou dans la nvram ?

Ça expliquerait tes fameuses lignes de code quand tu désactives le secure-boot. Autrement dit, ce sont peut-être des résidus de freedos, et non W10, qui provoquent ce message., car W10 n'a aucune raison de le provoquer.

Reply
réponses:
  • DocR

    Merci pour ton message. J'ai fini par le confier à un professionnel.
    J'ai bien essayé de formater avant, sans effet... merci pour votre aide.

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed