Somme d'heures selon n° semaine

Somme d'heures selon n° semaine Formule pour total des heures de la semaine (Résolu) » Forum - Bureautique Calculer heure de travail [Résolu] (Résolu) » Forum - Bureautique Convertir heures de travail en mois [Résolu] (Résolu) » Forum - Bureautique Conversion d'heures en jours, semaines et mois » Forum - Excel Calculer le total des heures de la semaine » Forum - Excel

Bonjour,

Voila je possède un planning sur excel dans lequel je voudrai réaliser la somme des heures effectuées par chaque ouvrier selon la semaine.

Mon problème étant que le planning étant adaptable à l'année, j'avais jusqu'ici réaliser cela avec une fonction
=SOMME(DECALER(D14:J16;;(COLONNE()-4)*6;;7))
Par exemple pour avoir la somme sur une plage de cellule, et a chaque fois décaler cette somme de 7 cellules

Seulement si je change l'année de mon planning, la nouvelle année ne commençant pas forcement par un lundi, les sommes le correspondent plus à une semaine unique et se chevauchent.

Fichier exemple ci-joint (feuille 1et 2), si je change la date dans la cellule D4 et mets par exemple une année commençant par un mercredi, cela décale tout au niveau des sommes.

https://www.cjoint.com/c/HJmjFBHwbau

Est-ce que l'un de vous aurez une idée comment faire cela ?
Merci !


Forum

Somme d'heures selon n° semaine Formule pour total des heures de la semaine (Résolu) » Forum - Bureautique Calculer heure de travail [Résolu] (Résolu) » Forum - Bureautique Convertir heures de travail en mois [Résolu] (Résolu) » Forum - Bureautique Conversion d'heures en jours, semaines et mois » Forum - Excel Calculer le total des heures de la semaine » Forum - Excel

Web: www.shapebootstrap.net

2 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour
mis à part le fait que certains titres de colonnes se répétent en fin de planning, si vous traitez seulement de B2 à ND2, vous devriez pouvoir écrire votre DECALER comme suit:

=SOMME(DECALER(Feuil1!$C$5;EQUIV($A2;Feuil1!$A$6:$A$26;0);EQUIV(B$1;Feuil1!$D$2:$NB$2;0);3;NB.SI(Feuil1!$D$2:$NB$2;B$1)))

attention aux signes pour tirer la formule

notez que le ;3; est à ajuster dans la formule selon la hauteur de champ de chaque rubrique en A
si vous aviez prévu un nombre de lignes constant (le maxi selon besoin) pour tous les postes en Feuil1 (quitte à en laisser plus de vides intercalées), cette formule pouvait couvrir tout le tableau sans modifier cette valeur

Et si vous voulez dépasser la S53 au delà de ND, prévoyez un code différent, par exemple S1/2019 à utiliser en titre dans les deux feuilles

crdlmnt

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour Geo, Vaucluse

autre formule pour Brother sur tout le tableau
en B2 à tirer vers la droite et vers le bas

=SOMMEPROD((Feuil1!$D$2:$BXX$2=B$1)*(Feuil1!$D7:$BXX7))+SOMMEPROD((Feuil1!$D$2:$BXX$2=B$1)*(Feuil1!$D8:$BXX8)) 

BXXX corrrespond à la colonne 2000 (exact nbre de jours: 1830)

ptite remarques::
dommage qu'on ne voit les heures arrondies à l'unité
Tous les ans il faut que tu refasse ce calendrier ?
Peut-être signaler les jours fériés (les heures comptent double)

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed