Nombre de trimestres qui débutent entre 2 dates [Résolu]

Nombre de trimestres qui débutent entre 2 dates Nombre de fin de mois entre deux dates (Résolu) » Forum - Excel Calcul de jours entre 2 dates avec calendrier personnalisé [Résolu] (Résolu) » Forum - Excel Déterminer un nombre de mois entre deux dates [Résolu] (Résolu) » Forum - Bureautique Calculer trimestre a partir de deux dates [Résolu] » Forum - Excel Formule pour donner le nombre de jour de retard entre deux dates » Forum - Excel

Bonjour,

voici ma problématique du jour :

A1 : date de début de période
B1 : Date de fin de période.

mon but : compter le nombre de trimestres civiles qui commencent durant cette période (1er janvier, 1er avril, 1er juillet et 1er octobre comptent chacun pour un).

Merci

Forum

Nombre de trimestres qui débutent entre 2 dates Nombre de fin de mois entre deux dates (Résolu) » Forum - Excel Calcul de jours entre 2 dates avec calendrier personnalisé [Résolu] (Résolu) » Forum - Excel Déterminer un nombre de mois entre deux dates [Résolu] (Résolu) » Forum - Bureautique Calculer trimestre a partir de deux dates [Résolu] » Forum - Excel Formule pour donner le nombre de jour de retard entre deux dates » Forum - Excel

Web: www.shapebootstrap.net

5 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Un essai (il y a surement d'autres façons !)

https://www.cjoint.com/c/HJmrzgzcFM0

Crdlmt

Reply
réponses:
  • xuorel

    merci pour ton retour.
    tu peux m'expliquer un peu le raisonnement ?
    notamment pourquoi les valeurs dans le cadre bleu vont de 3 à 0 ?

    Ma problématique est qu'en faite je dois faire ce calcul sur plusieurs lignes (plusieurs intervalles de dates).
    Dans le meilleur des monde, te calcul devrait se faire dans une seule cellule.

    Bonne soirée

  • DjiDji59430

    Parce que la première année, a moins de commencer le 1 janvier tu ne peux avoir que 3 trimestres ou si tu commence le 1er janvier, une année compléte (comptabilisée par le datedif()

    re https://www.cjoint.com/c/HJnnXTKoCp0
    A vérifier

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour

En reprenant les dates début-fin du classeur de djidji que je salue (C5 debut C6 fin)

=(ENT((MOIS(C6)+2)/3)-ENT((MOIS(C5)+2)/3))+1+(ANNEE(C6)-ANNEE(C5))*4

ENT((MOIS(C5)+2)/3) donne le trimestre de la date en C5 (formule de Monique sur XLD)

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

merci pour vos réponses à tous les deux.
J'ai re-planché sur vos propositions et j'ai corrigé 1 ou 2 incohérences de résultat sur les dates charnières.

En combinant vos 2 propositions pour obtenir une formule n'utilisant pas de tables de recherches avec recherchev, j'obtiens la formule suivante qui a l'air de fonctionner dans tous les cas :

si C5 début et C6 fin

=SI((C5=DATE(ANNEE(C5);(ENT((MOIS(C5)+2)/3)-1)*3+1;1));(5-ENT((MOIS(C5)+2)/3));(4-ENT((MOIS(C5)+2)/3)))+ENT((MOIS(C6)+2)/3)+(ANNEE(C6)-ANNEE(C5)-1)*4

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed