Gestionnaire Hyper-V impossible de se connecter à mon serveur [Résolu]

A voir également:Impossible de me connecter a mon serveur 2016Gestionnaire hyper v vous ne disposez pas de l'autorisation - Forum - Réseau Se connecter à un serveur - Forum - Réseau Se connecter à un serveur local - Forum - Réseau Emule ne se connecte pas aux serveurs ✓ - Forum - Internet / Réseaux sociaux Se connecter à un serveur à distance ✓ - Forum - Windows

Lexique :
ma machine = le pc sous Win10 Pro depuis lequel je me connecte sur le serveur
mon serveur = le serveur tournant sous Microsoft Hyper-V Server 2016 ayant pour nom ***




Bonjour,

Je vais tenter de m'expliquer du mieux que je peux étant débutant dans ce domaine..

Donc voici mon problème :
J'ai installé Windows Hyper-V Server 2016 en suivant le tuto de Microsoft sur mon serveur (le serveur est chez moi).
L'installation se passe correctement mais lorsque j'essaye de me connecter une première fois à mon serveur depuis un autre ordinateur avec le Gestionnaire Hyper-V de Windows 10 (Pro), je reçois une erreur (que je n'ai pas notée puisque je l'ai corrigée) indiquant que je devais utiliser winrm quickconfig.
Sitôt dit, sitôt fait : j'exécute cette commande.

Je tente alors de me connecter une nouvelle fois au serveur. Celui-ci ne l'entendant pas de cette oreille, je reçois le message :

Une erreur s'est produite lors de la tentative de connexion au serveur "***". Vérifiez que le service de gestion d'ordinateurs virtuels s'exécute et que vous êtes autorisés à vous connecter au serveur.

Échec de l'opération sur l'ordinateur *** : Le client WinRM ne peut pas traiter la demande. Si le modèle d'authentification n'est pas Kerberos, ou si l'ordinateur n'es pas membre d'un domaine d'un domaine, le transport HTTPS doit être utilisé ou l'ordinateur de destination doit être ajouté au paramètre de configuration TrustedHosts. Notez que les ordinateurs dans la liste TrustedHists ne sont peut-être pas authentifiés. Pour plus d'informations, exécutez la commande suivant : winrm help config


Ayant exécuter la dite commande dans le serveur (winrm help config), la console me retourne plusieurs commandes qui sont sensées m'aider (j'imagine).
Je décide de ne rien en faire puisque les descriptions n'ont pas l'air de correspondre à mon problème (quoique je ne sais pas si j'ai bien cerné le problème...).

Je cherche ensuite des solutions sur des forums. Une solution m'a fait avancer (je crois) :
La solution proposée était d'ajouter le serveur au TrustedHosts de ma machine (d'après ce que j'ai compris) :
  • Dans un PowerShell en admin*

Start-Service WinRM
winrm set winrm/config/client '@{TrustedHosts='***'}' /*retourne une sorte de "compte-rendu" des paramètres de WinRM*/
Stop-Service WinRM
  • Fin*


J'obtiens depuis, mais pas à chaque fois (étrange ..), une nouvelle erreur qui indique cette fois-ci un code d'erreur 0x8009030e. L'erreur indique plus en détail :

Une erreur s'est produite lors de la tentative de connexion au serveur "***". Vérifiez que le service de gestion d'ordinateurs virtuels s'exécute et que vous êtes autorisés à vous connecter au serveur.

Échec de l'opération sur l'ordinateur *** : Le client WinRM ne peut pas traiter la demande. L'erreur suivant s'est produite avec le code 0x8009030e lors de l'utilisation de l'authentification Negotiate : Une ouverture de session spécifiée n'existe pas. Elle est peut-être déjà terminée.


J'ai tenté de chercher des solutions pour ce problème mais je ne vois vraiment pas. Aussi, il y a le mode d'authentification Negotiate que je n'ai jamais paramétré et je ne sais pas d'où il peut venir, à moins que ce soit le mode par défaut...

Merci de m'avoir lu
et merci d'avance de m'aider


Fixir

Forum

A voir également:Impossible de me connecter a mon serveur 2016Gestionnaire hyper v vous ne disposez pas de l'autorisation - Forum - Réseau Se connecter à un serveur - Forum - Réseau Se connecter à un serveur local - Forum - Réseau Emule ne se connecte pas aux serveurs ✓ - Forum - Internet / Réseaux sociaux Se connecter à un serveur à distance ✓ - Forum - Windows

Web: www.shapebootstrap.net

1 réponse

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Le compte utilisé pour vous authentifié appartient bien au groupe "administrateurs hyperv" côté serveur...
L'idéal eu été d'avoir un domaine. Plus facile pour ne pas avoir de problème d'authentification comme vous rencontrez en ce moment.
A défaut, le serveur et le poste utilisateur appartiennent bien au même groupe de travail...

Cdlt.

Reply
réponses:
  • auteur

  • auteur

    Lorsque je me connecte je ne rentre aucun identifiant et aucun ne me sont demandé sauf si je choisis de me connecter en tant qu'autre utilisateur (lors de la sélection d'un ordinateur dans le gestionnaire).
    Sauf que lorsque j'utilise cette fonction, il me dit que le nom d'utilisateur n'est pas valide (et quel que soit ce que je rentre dedans).
    Aussi pour le moment, il n'y a qu'un compte sur le serveur et c'est celui créé à l'installation (Administrateur).

    Sinon, oui le serveur et le poste sont bien dans le même groupe de travail vu que les deux affichent WORKGROUP dans la section groupe de travail.
    De plus, les deux machines sont sur le même LAN, ils ne devraient pas avoir de problème pour se voir (d'ailleurs je peux ping le serveur avec le poste).

    Merci de m'avoir répondu

  • auteur

    Justement il faut choisir autre utilisateur.
    Malgré tout si le compte administrateur n'appartient pas au groupe administrateur hyperv, vous ne pourrez l'administrer à distance.
    Ensuite à distance pour vous authentifié il faut écrire l'identifiant sous la forme nomduseveur\administrateur (remplacer nomduserveur par le nom de votre serveur hyperv).

  • auteur

    J'ai tenté de me connecter au serveur avec la syntaxe "qui va bien". En effet ça marche mieux.
    Mais j'obtiens un message d'erreur (encore) qui indique qu'il faut configurer l'authentification CredSSP sur le client local.
    Chose que je tente de faire après quelques recherches rapides : je tombe sur une commande
    Enable-WSMan-CredSSP -Role Client -DelegateComputer ***
    Et là, ça me retourne une erreur : "Le client ne peut pas se connecter à la destination spécifiée dans la demande. Vérifiez que le service est en cours d'exécution sur la destination et qu'il accepte les demandes."
    Il y a aussi le code d'erreur 2150858770.
    Je ne sais pas si ma syntaxe est mauvaise ou s'il y a un problème sur le WinRM du serveur.

  • auteur

    En coupant le firewall des 2 côtés, le problème persiste-t-il ?

  • auteur

    Oui j'ai toujours le même problème

  • auteur

    A voir aussi pour bien configurer Winrm https://www.it-connect.fr/powershell-remoting-avec-winrm/
    A vérifier aussi https://www.virtualease.fr/windows-server-configuration-winrm-remote-powershell/

  • auteur

    Je pense du coup que j'ai bien configurer WinRM puisque j'arrive à la fin du tuto à me connecter avec PSSession sur le serveur depuis le poste.
    Par contre depuis le Gestionnaire Hyper-V toujours impossible.

  • auteur

    Je pense du fait qu'aucun poste n'est lié à un domaine, vous ne puissiez pas vous connectez à distance. Il y'a 5, 6 ans, j'avais déjà fait des tests la dessus, le serveur et le poste client intégrés dans un domaine, aucun souci par contre en groupe de travail impossible de s'authentifier à distance.

  • auteur

    Ah ok,
    Mais du coup pour créer des VM je passe par la ligne de commande ?

  • auteur

    vous pouvez installer le gui => https://4sysops.com/archives/how-to-install-the-gui-on-windows-server-2016/

  • auteur

    En fait, je ne peux pas puisque ce n'est pas Windows Server 2016 mais l'Hyper-V Server 2016.
    Mais c'est pas grave, j'apprendrai à les créer en ligne de commande...

    Merci beaucoup de m'avoir aidé même si ça n'a pas marché et je ferme le sujet.

    Bonne journée

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed