Faire évoluer une case de+1ou-1 selon texte qui apparait dans un menu déroulant

A voir également:Faire évoluer une case de+1ou-1 selon texte qui apparait dans un menu déroulantJavascript+menu+déroulant+cases+à+cocher - Forum - Programmation Menu déroulant case excel - Conseils pratiques - Excel Créer menu déroulant avec cases de choix ✓ - Forum - Excel CSS - Lien case menu déroulant ✓ - Forum - CSS Lien case à cocher et menu déroulant Word ✓ - Forum - Word

Bonjour,

Je travaille pour une société qui loue les services de chauffeurs. J'aimerai pouvoir faire évoluer le nombre de jours de récupération de -1 ou +1 selon que le statut du menu déroulant indique "récupération journée" ou "jour à reprendre".

Je vous joins une image po

ur une meilleure compréhension. J'aimerai que la case E14 évolue de +1 ou de moins 1 selon le texte sélectionné dans mon menu déroulant.

Je vous remercie d'avance pour votre aide.

Maxime

Configuration: Macintosh / Chrome 70.0.3538.110

Forum

A voir également:Faire évoluer une case de+1ou-1 selon texte qui apparait dans un menu déroulantJavascript+menu+déroulant+cases+à+cocher - Forum - Programmation Menu déroulant case excel - Conseils pratiques - Excel Créer menu déroulant avec cases de choix ✓ - Forum - Excel CSS - Lien case menu déroulant ✓ - Forum - CSS Lien case à cocher et menu déroulant Word ✓ - Forum - Word

Web: www.shapebootstrap.net

6 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,
L'image est presque illisible car trop petite

D'autre part, sur un forum traitant EXCEL, il serait plus opportun de placer un classeur exemple Excel qu'une photo !

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57187 internautes nous ont dit merci ce mois-ci

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

bonjour, je suppose que tu souhaites additionner ou soustraire 1 à une valeur de la colonne E. A quel moment veux-tu faire cela?

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Oui exactement. Sachant que la colonne E correspond au nombre de jours de récupérations restant aux chauffeurs. +1 s'ils en cumulent, -1 s'ils en prennent.
Est-ce que c'est plus clair ?

Merci,

Reply
réponses:
  • auteur

    A quel moment veux-tu faire cela?

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonsoir,
Si j'ai bien compris :

Formule en E14 : =$D$13-$D$24

Reply
réponses:
  • auteur

    Bonjour,

    Merci pour votre réponse.

    La colonne C (à partir de C14) propose un menu déroulant indiquant "Jour travaillé" ou "Jour de WE travaillé" ou "Jour à reprendre" ou "Vacances journée" ou "Récupération journée" ou "Férié" ou "Maladie".

    J'ai réussi à faire en sorte que le solde de vacances (en colonne D) évolue à la baisse automatiquement lorsque "Vacances journée" est sélectionné dans le menu déroulant.
    Exemple avec la ligne 20 : =SI(NB.SI(C20;"*vacance*");D19-1;D19)
    Dans ce cas c'est assez simple car on octroie un solde de vacances en début d'année, qui n'est amené qu'à baisser en cours d'année.

    La problématique de la colonne E est la suivante : j'aimerai que E23 augmente de +1 si "Jour à prendre" est sélectionné dans le menu déroulant de C23, ou que E23 diminue de -1 si "récupération journée" est sélectionné dans le menu déroulant de C23. Et je ne sais pas comment y arriver.

    J'espère que c'est plus clair. je vous remercie pour votre aide et vous souhaite une excellente journée.

    Maxime

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Je pense qu'il vas falloir réaliser une fonction "SI" mais ils fraudait plus d'information sur les cellules..
Dans la cellule E14 tu veut seulement afficher +1 ou -1 ? Ou veut tu réaliser une opération par rapport à une autre cellule ?

Reply
réponses:
  • auteur

    Bonjour,

    Merci pour votre réponse.

    La colonne C (à partir de C14) propose un menu déroulant indiquant "Jour travaillé" ou "Jour de WE travaillé" ou "Jour à reprendre" ou "Vacances journée" ou "Récupération journée" ou "Férié" ou "Maladie".

    J'ai réussi à faire en sorte que le solde de vacances (en colonne D) évolue à la baisse automatiquement lorsque "Vacances journée" est sélectionné dans le menu déroulant.
    Exemple avec la ligne 20 : =SI(NB.SI(C20;"*vacance*");D19-1;D19)
    Dans ce cas c'est assez simple car on octroie un solde de vacances en début d'année, qui n'est amené qu'à baisser en cours d'année.

    La problématique de la colonne E est la suivante : j'aimerai que E23 augmente de +1 si "Jour à prendre" est sélectionné dans le menu déroulant de C23, ou que E23 diminue de -1 si "récupération journée" est sélectionné dans le menu déroulant de C23. Et je ne sais pas comment y arriver.

    J'espère que c'est plus clair. je vous remercie pour votre aide et vous souhaite une excellente journée.

    MaximeBonjour,

    Merci pour votre réponse.

    La colonne C (à partir de C14) propose un menu déroulant indiquant "Jour travaillé" ou "Jour de WE travaillé" ou "Jour à reprendre" ou "Vacances journée" ou "Récupération journée" ou "Férié" ou "Maladie".

    J'ai réussi à faire en sorte que le solde de vacances (en colonne D) évolue à la baisse automatiquement lorsque "Vacances journée" est sélectionné dans le menu déroulant.
    Exemple avec la ligne 20 : =SI(NB.SI(C20;"*vacance*");D19-1;D19)
    Dans ce cas c'est assez simple car on octroie un solde de vacances en début d'année, qui n'est amené qu'à baisser en cours d'année.

    La problématique de la colonne E est la suivante : j'aimerai que E23 augmente de +1 si "Jour à prendre" est sélectionné dans le menu déroulant de C23, ou que E23 diminue de -1 si "récupération journée" est sélectionné dans le menu déroulant de C23. Et je ne sais pas comment y arriver.

    J'espère que c'est plus clair. je vous remercie pour votre aide et vous souhaite une excellente journée.

    Maxime

  • auteur

    Essaye ça :

    =SI(OU(C23<>"Jour travaillé";C23<>"Récupération Journée");SI(C23="Jour travaillé";1;SI(C23="Récupération Journée";-1;));"")

    Fais attention à ce que qu'il y a entre les guillemets soit exactement de la même orthographe que ta liste déroulante.

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Merci pour votre réponse.

La colonne C (à partir de C14) propose un menu déroulant indiquant "Jour travaillé" ou "Jour de WE travaillé" ou "Jour à reprendre" ou "Vacances journée" ou "Récupération journée" ou "Férié" ou "Maladie".

J'ai réussi à faire en sorte que le solde de vacances (en colonne D) évolue à la baisse automatiquement lorsque "Vacances journée" est sélectionné dans le menu déroulant.
Exemple avec la ligne 20 : =SI(NB.SI(C20;"*vacance*");D19-1;D19)
Dans ce cas c'est assez simple car on octroie un solde de vacances en début d'année, qui n'est amené qu'à baisser en cours d'année.

La problématique de la colonne E est la suivante : j'aimerai que E23 augmente de +1 si "Jour à prendre" est sélectionné dans le menu déroulant de C23, ou que E23 diminue de -1 si "récupération journée" est sélectionné dans le menu déroulant de C23. Et je ne sais pas comment y arriver.

J'espère que c'est plus clair. je vous remercie pour votre aide et vous souhaite une excellente journée.

Maxime

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed