Formule complexe excel

A voir également:Formule complexe excelFormule complèxe EXCEL ✓ - Forum - Excel Formule complexe excel ! ✓ - Forum - Excel Aide sur 2 formules compléxes sous excel ✓ - Forum - Excel EXCEL FORMULE COMPLEXE ✓ - Forum - Excel Formule si excel - Conseils pratiques - Excel

Bonjour,

N'étant pas une experte sur Excel, je n'arrive pas à rentrer une formule qui me permettrait d'avoir le résultat pour un cas comme celui ci :

Si B1 < D1 alors le résultat = C1 - B1 sinon = 0
Mais si B1< D1 et que C1>D1 alors le résultat = C1 - D1
Mais si B1 < D1, que C1>D1 et que le résultat C1 - D1 est > ou = à 8 alors il sera égale à 8

J'ai fait tout un tas de formules avec SI ET OU CONDITIONS mais j'ai un message d'erreur à chaque fois.

La dernière formule utilisé est la suivante mais ça n'a pas marché (je m'en doutais un peu) :

=SI(B1<D1;(C1-B1);(0);SI(ET(B1>D1;C1>D1;(C1-D1);SI(C1-D1>=8);(8))))

Merci pour vos aides si précieuses car là je ne m'en sorts pas du tout et j'en ai vraiment besoin!!!

Forum

A voir également:Formule complexe excelFormule complèxe EXCEL ✓ - Forum - Excel Formule complexe excel ! ✓ - Forum - Excel Aide sur 2 formules compléxes sous excel ✓ - Forum - Excel EXCEL FORMULE COMPLEXE ✓ - Forum - Excel Formule si excel - Conseils pratiques - Excel

Web: www.shapebootstrap.net

2 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour
peut être avec:
=SI(B1<D1;B1-C1;SI(ET(B1>D1;C1>D1);MIN(C1-D1;8))
crdlmnt

Reply
réponses:
  • auteur

    Merci beaucoup Vaucluse pour cette réponse rapide.
    Malheureusement le résultat est erroné car il ne prend pas en compte cette partie :
    "si le résultat C1 - D1 est > ou = à 8 alors il sera égale à 8 "
    Auriez-vous une autre proposition Vaucluse?
    Cordialement

  • auteur

    une autre proposition

    =SI(ET(B1<D1;C1>D1;C1-D1>=8);8;C1-D1)

  • auteur

    Bonjour yclik,

    J'ai voulu faire simple mais peut-être qu'en procédant de la sorte j'ai omis des éléments qui sont peut-être nécessaire dans la formule.

    Donc pour être plus précise :

    Si B1 < D1 alors le résultat = C1 - B1 sinon = 0
    Mais si B1< D1 et que C1> D1 alors le résultat = C1 - D1
    Mais si B1< D1 et que C1 < D1 alors le résultat = C1 - B1
    Et si B1 < D1, que C1> D1 et que le résultat C1 - D1 est > ou = à 8 alors il sera égale à 8
    Mais si B1 < D1, que C1> D1 et que le résultat C1 - D1 est < 8 le résultat sera D1 - B1

    Lorsque je rentre votre formule yclik, le résultat obtenu correspond pour faire simple à la formule : C1 - D1

    Merci beaucoup pour votre réponse, cependant ayant été un peu plus clair auriez-vous autre chose à me proposer?

  • auteur

    Ou sinon une formule peut être plus simple comportant au moins :
    Si B1 < D1 alors le résultat = C1 - B1 sinon = 0
    Mais si B1< D1 et que C1> D1 alors le résultat = C1 - D1 sinon = C1 - B1

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Mais si B1< D1 et que C1> D1 alors le résultat = C1 - D1
Mais si B1< D1 et que C1 < D1 alors le résultat = C1 - B1

il manque le cas B1= D1
J'ai fait C1>D1, et donc C1 <= D1

=SI(B1>=D1;0;SI(C1>D1;MIN(8;C1-D1);C1-B1)) 

eric
En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed