Formule SI et INDIRECT - Excel

A voir également:Formule si et indirectFormule indirect onglet ✓ - Forum - Excel Formule Indirect ✓ - Forum - Excel Décaler une formule indirect ✓ - Forum - Excel Pb formule INDIRECT ✓ - Forum - Bureautique Excel validation avec formule INDIRECT ✓ - Forum - Excel

Bonsoir le Forum,

Comment formuler ceci SVP :
La Cellule W6 (feuille VTS) est égale à celle contenue dans la colonne ART!M:M si le paramètre B6 (feuille VTS) est lui même contenu dans la colonne ART!B:B et si les cellules de la colonne G:G (feuille VTS) contiennent la mention "PRS"
Nota : W6, B6 et G:G avec "PRS" sont dans la feuille VTS et la valeur recherchée dans la feuille ART, colonne M:M.
Le paramètre commun aux deux feuilles est dans les colonnes B:B des deux feuilles.

Cette formule fonctionne bien, mais je n'arrive pas à intégrer la condition "PRS" contenue dans la feuille VTS en colonne G:G
W6=SIERREUR(INDEX(ART!$M:$M;EQUIV(I6;ART!$B:$B;0));"")

Vous allez peut être me demander un fichier, mais ça sera assez compliqué puisque le fichier en question contient 60 onglets et qu'il faudra du temps pour le préparer. Je le fournirais si la formulation ci dessus ne permet pas d'apporter une solution.

Merci d'avance pour votre assistance
Cordialement
Fat



Configuration: iPhone / Safari 12.0

Forum

A voir également:Formule si et indirectFormule indirect onglet ✓ - Forum - Excel Formule Indirect ✓ - Forum - Excel Décaler une formule indirect ✓ - Forum - Excel Pb formule INDIRECT ✓ - Forum - Bureautique Excel validation avec formule INDIRECT ✓ - Forum - Excel

Web: www.shapebootstrap.net

2 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Question: Pourquoi I6 dans votre formule: W6=SIERREUR(INDEX(ART!$M:$M;EQUIV(I6;ART!$B:$B;0));"") , n'est-ce pas plutôt B6?

Sinon si j'ai bien compris:
=SIERREUR(SI(EQUIV("PRS";$G:$G;0)<>"";INDEX(ART!$M:$M;EQUIV(B6;ART!$B:$B;0)));"")

Cdlt

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour

vous ne dites pas quelle est le critère qui permet de détecter PRS dans la colonne G:G????

  • si PRS est n'importe où dans la colonne, la proposition de Frenchie (salut) convient
  • si on suppose qu'il est sur la même ligne que le B cherche (mais ça paraît trop simple pour être exact-):

=SIERREUR(SI(G6<>"PRS";"";INDEX(ART!$M:$M;EQUIV(B6;ART!$B:$B;0)));"")
  • et s'il faut aller chercher la ligne où se trouve B6, il faut nous dire dans quelle colonne de la feuille VTS il faut chercher

dans ce cas la formule devient
=SIERREUR(SI(INDEX(G:G;EQUIV(B6;colxx?;0))<>"PRS";"";INDEX(ART!$M:$M;EQUIV(B6;ART!$B:$B;0)));"")

crdlmnt
--

Reply
réponses:
  • auteur

    Le I6 dans VTS est un code qu’on retrouve dans la colonne B:B de la feuille ART. C’est le dénominateur commun aux deux feuilles.
    Je cherche à rajouter le paramètre de la colonne G:G qui contient uniquement la mention “PRS”

  • auteur

    heu, ça ne répond pas à ma question? quel est l'argument qui permet de détecter quel G doit être pris en compte

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed