Serveur Dns [Résolu]

A voir également:Serveur dnsServeur dns ne repond pas ✓ - Forum - Internet / Réseaux sociaux Serveur dns indisponible - Forum - DNS Serveur dns google - Conseils pratiques - Connexion Serveur dns gratuit - Conseils pratiques - DNS Le serveur DNS ne réponds pas - Forum - DNS

Bonjour, j'ai un problème avec le DNS.

Lorsque je met l'adresse de mon serveur DNS 192.168.1.1 (Livebox) ou l'adresse du serveur DNS Google 8.8.8.8 même les différents masques dans le fichier et en redémarrant le service networking, il met impossible d'accéder à une page sur le net.

Je vais donc dans le fichier resolv.conf mettre "nameserver 192.168.1.1" qui correspond à la livebox.
Je redémarre le service networking, il possible d'accéder à une page sur le net.

Lorsque je redémarre ma machine ou que je l'éteins, le contenu du fichier resolv.conf est vide, il s'efface . Je dois a chaque fois remettre "nameserver 192.168.1.1" et redémarrer le service networking pour pouvoir aller sur le web.

Comment faire pour résoudre ce problème ? Merci de votre aide.

Forum

A voir également:Serveur dnsServeur dns ne repond pas ✓ - Forum - Internet / Réseaux sociaux Serveur dns indisponible - Forum - DNS Serveur dns google - Conseils pratiques - Connexion Serveur dns gratuit - Conseils pratiques - DNS Le serveur DNS ne réponds pas - Forum - DNS

Web: www.shapebootstrap.net

1 réponse

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Peux-tu préciser la distribution + version ?
NetworkManager est-il installé ? (sûrement "oui" si tu es dans un environnement graphique)

« Lorsque je met l'adresse de mon serveur DNS 192.168.1.1 [...] dans le fichier et en redémarrant le service networking, il met impossible d'accéder à une page sur le net. »
Peux-tu préciser le fichier que tu modifies, et son contenu ?

Le fichier resolv.conf est souvent généré par les autres "couches" lors du boot du système, en général, il ne doit pas être modifié.

Vérifie les configuration de ta connexion :

via NetworkManager si installé (nmcli, nmtui ou via l'interface graphique)
sinon, si pas de NetworkManager, via les fichiers de conf :
- /etc/netplan/xxx.yaml sous Ubuntu récents
- /etc/network/interfaces sous Ubuntu/Debian
- /etc/sysconfig/network-scripts/ifcfg-xxx sous Fedora/RHEL/CentOS

Reply
réponses:
  • auteur

    j'utilise Debian 9.7.0. Je dévute sur Linux donc je ne connais pas NetworkManager mais oui j'utilise l'interface graphique.

  • auteur

    Salut,

    Dans ce cas, tu peux renseigner les DNS que tu souhaites utiliser via le panneau de configuration graphique, ou alors, modifier le fichier /etc/network/interfaces pour y renseigner ces DNS.

    Précédemment, tu mentionnais que tu modifiais un fichier (autre que resolv.conf), s'agissait-il bien de /etc/network/interfaces ? Avec l'instruction « dns-nameservers » ?
    Peux-tu montrer ici son contenu ?

  • auteur

    si je ne met que dans /etc/network/interfaces ca ne marche pas alors que c'est avec dns-nameservers

  • auteur

    Correction :

    Sous Debian, lorsque NetworkManager est utilisé (ce qui est sûrement le cas si tu utilises Gnome), alors NetworkManager charge les config réseau via les fichiers « /etc/NetworkManager/system-connections/Nom de la connexion ».

    C'est ce qu'indique la doc, en tout cas :
    https://wiki.debian.org/NetworkConfiguration#DNS_configuration_for_NetworkManager

    Et donc, NetworkManager semble ignorer /etc/network/interfaces


    Je n'avais pas mentionné ces fichiers précédemment car, sous Fedora (le système que j'utilise), NetworkManager utilise directement les fichiers de config réseau propres à Fedora/RHEL/CentOS et donc les fichiers « /etc/sysconfig/network-scripts/ifcfg-xxx », en tout cas pour les connexions câblées/WiFi. Les fichiers /etc/NetworkManager/system-connections/xxx sont plutôt utilisés pour les autres connexions qui ne sont pas gérées directement par le système de base (VPN et mobiles par exemple).

    Voir ici : https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Networking_Guide/sec-Network_Configuration_Using_sysconfig_Files.html

    Pour faire court : tu disposes probablement de NetworkManager, c'est un utilitaire permettant de gérer tes connexion réseaux et qui bascule d'une à l'autre afin de s'assurer que tu sois toujours connecté. Tu dois donc modifier les configurations réseau via son interface graphique ou ses programmes en ligne de commande (nmcli ou nmtui). Si tu modifies les fichiers de configuration à la main, il faut l'indiquer à NetworkManager (commande : nmcli connection reload). Sous Debian, NetworkManager semble ignorer le fichier /etc/network/interfaces et utilise ses propres fichiers (/etc/NetworkManager/system-connections/xxx) pour toutes les connexions. Le fichier /etc/resolv.conf est écrasé par NetworkManager, il ne faut donc pas y apporter de modification permanente.

  • auteur

    bonsoir, j'ai vu qu'il faillait utilisé la commande d'un site.

    Voila ce qui est dit :
    "Le fichier est créé lors de l'installation dans /etc/resolv.conf. S'il manque, il suffit de le créer, en root.
    Certains programmes tels que dhcpcd, networkmanager, etc… peuvent modifier votre /etc/resolv.conf. C'est un comportement normal . Si pour une raison ou une autre, vous voulez spécifier des options différentes, vous pouvez empêcher la modification de ce fichier : alors faite un chattr +i /etc/resolv.conf."

    L'erreur ci-dessous s'affiche
    chattr: Opération non supportée lors de la lecture des drapeaux sur resolv.conf

    J'ai voulu installer le paquet resolvconf mais il n'est pas connu?

    Bref toujours le même problème.

  • auteur

    La solution proposée, empêcher que resolv.conf soit regénéré en bloquant son accès, c'est une fausse bonne idée. En effet, si tu connectes ton PC à un autre réseau, avec un autre DNS, alors tu devras toujours modifier ce fichier manuellement. Si tu veux utiliser un VPN avec son propre DNS, idem. Pour l'erreur que tu obtiens, as-tu bien exécuté cette commande en root ?

    Si ton Debian utilise NetworkManager, il faut donc modifier ta connexion via NetworkManager, donc graphiquement (via le panneau "Paramètres > ") ou avec nmcli ou nmtui.

    Pour vérifier si ton système utilise NetworkManager, tu peux utiliser « systemctl status NetworkManager » ou « nmcli --version » par exemple.

  • auteur

    je n'ai pas NetworkManager.

  • auteur

    rien ne change. Je ne comprends pas pourquoi ça fait ça alors que je suis en statique.

  • auteur

    Si ce n'est pas NetworkManager, l'interférent est peut-être resolvconf.
    Jette un œil à ceci ;)
    https://wiki.debian.org/NetworkConfiguration#The_resolvconf_program

    Essaie donc de définir tes DNS dans /etc/network/interfaces

  • auteur

    j'ai reussi avec NetworkManager

  • auteur

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed