Somme avec 3 conditions sur période [Résolu]

A voir également:Somme avec 3 conditions sur périodeSomme si 3 conditions ✓ - Forum - Excel Somme avec trois conditions ✓ - Forum - Excel Somme.si.ens avec 3 conditions... 2 en colonnes et une en ligne ✓ - Forum - Excel 3 conditions pour une somme ✓ - Forum - Bureautique Faire une somme sur 2 ou 3 conditions ✓ - Forum - Bureautique

Bonjour,

Je souhaite rapprocher des données de 2 fichiers en utilisant plusieurs clés d'entrées : un numéro d'agent ainsi que des dates.
La problématique étant que pour une même période dans un fichier nous n'avons qu'une ligne et que dans le deuxième fichier, la période peut être scindée en plusieurs lignes.

1er fichier : (Colonne de A à J) > formules en J

NUM NOM PRENOM DEB P1 FIN P2 B TT Montant récupéré
10 TOTO X X 27/08/2018 M 31/08/2018 S 10 1110 633,05
10 TOTO X X 03/09/2018 M 07/09/2018 S 10 1110 728,01

10 TOTO X X 27/08/2018 M 07/09/2018 S 10 1110 0

J3=SOMMEPROD(([Fichier2.xlsx]Feuil1!$A$2:$A$49999=$A2)*([Fichier2.xlsx]Feuil1!$D$2:$D$49999=$D2)*([Fichier2.xlsx]Feuil1!$E$2:$E$49999=$F2)*([Fichier2.xlsx]Feuil1!$J$2:$J$49999))

J4=SOMMEPROD(([Fichier2.xlsx]Feuil1!$A$2:$A$49999=$A3)*([Fichier2.xlsx]Feuil1!$D$2:$D$49999=$D3)*([Fichier2.xlsx]Feuil1!$E$2:$E$49999=$F3)*([Fichier2.xlsx]Feuil1!$J$2:$J$49999))


J6=SOMMEPROD(([Fichier2.xlsx]Feuil1!$A$2:$A$49999=$A5)*([Fichier2.xlsx]Feuil1!$D$2:$D$49999=$D5)*([Fichier2.xlsx]Feuil1!$E$2:$E$49999=$F5)*([Fichier2.xlsx]Feuil1!$J$2:$J$49999)) .......je devrais avoir 1361.06 (633.05+728.01) au lieu de 0 .

2ème fichier source : (colonnes de A à J)

NUM NOM AN DEB FIN NB A TOT AUTRE MONTANT
10 TOTO X 2018 27/08/2018 31/08/2018 5 J 2340 2912,04 633,05
10 TOTO X 2018 03/09/2018 07/09/2018 5 J 2340 2912,04 728,01

Si pas de solution par formule, je prend une solution par macro....

Quand la période est éclatée sur 2 lignes, sommeprod ne fonctionne pas...Je souhaite récupérer le montant total sur la période que ce soit en 1 ligne ou 2 lignes.

Merci d'avance pour votre aide !

Cordialement,



Configuration: Windows / Internet Explorer 11.0

Forum

A voir également:Somme avec 3 conditions sur périodeSomme si 3 conditions ✓ - Forum - Excel Somme avec trois conditions ✓ - Forum - Excel Somme.si.ens avec 3 conditions... 2 en colonnes et une en ligne ✓ - Forum - Excel 3 conditions pour une somme ✓ - Forum - Bureautique Faire une somme sur 2 ou 3 conditions ✓ - Forum - Bureautique

Web: www.shapebootstrap.net

1 réponse

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Le traitement doit se faire sur 15.000 lignes à minima, sommeprod est consommateur de mémoire et délai de réponse. Une macro serait-elle préférable ?

Reply
réponses:
  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

  • auteur

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed