La derniere valeur dans une colonne [Résolu]

Excel dernière valeur d'une colonne Dernière valeur d'une colonne excel Excel afficher dernière valeur colonne Utiliser dernière valeur d'une colonne Excel (Résolu) » Forum - Bureautique Filtre Excel pour les 20 dernières valeurs de la colonne » Forum - Excel Extraire valeurs d'une colonne sans doublons (Résolu) » Forum - Bureautique Recherche la dernière valeur d'une colonne (Résolu) » Forum - Bureautique Moyenne des 3 dernières valeurs d'une colonne (Résolu) » Forum - Bureautique

Forum

Excel dernière valeur d'une colonne Dernière valeur d'une colonne excel Excel afficher dernière valeur colonne Utiliser dernière valeur d'une colonne Excel (Résolu) » Forum - Bureautique Filtre Excel pour les 20 dernières valeurs de la colonne » Forum - Excel Extraire valeurs d'une colonne sans doublons (Résolu) » Forum - Bureautique Recherche la dernière valeur d'une colonne (Résolu) » Forum - Bureautique Moyenne des 3 dernières valeurs d'une colonne (Résolu) » Forum - Bureautique

Web: www.shapebootstrap.net

24 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour Eric,Vaucluse

Une alternative avec une fonction personnalisée:

Function derlig(col As String)
derlig = Range(col & Range(col & "65536").End(xlUp).Row)
End Function

Autres possibilités par formule (au cas où)

si il n'y a que des textes
=recherchev(car(255);A:A;1)

si il n'a que des nombres
=recherchev(9^9;A:A;1)
Cette réponse vous a-t-elle aidé ?  

Reply
réponses:
  • auteur

  • Vaucluse

    Bravo

  • auteur

    énorme !
    un grand merci

  • auteur

    très utile merci !

  • auteur

    Par formule : très élégant et tout simplement génial. Un grand bravo.

  • auteur

    Information plus qu'utile ! C'est pro c'est propre.
    Un grand merci a vous !

  • auteur

    merci,
    j'ai adapté la fonction avec une recherche H pour l'avoir en ligne! que du bonheur!
    du coup tous les #N/A ne me posent plus de soucis.

    formule adapté :
    =RECHERCHEH(9^9;D5:BB5;1)

  • auteur

    Merci pour cette formule, c'est ce qu'il me fallait. bravo.

  • auteur

    merci beaucoup. =recherchev(car(255);A:A;1) fonctionne super
    simple et efficace. Que du bonheur après pas mal de recherches!

  • auteur

    =recherchev(9^9;A:A;1) Fonctionne A1! Simple et efficace. Merci beaucoup!

  • auteur

    super génial mille merci

  • auteur

    un grand merci c'est exactement ce que j'avais besoin! :)

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour
Deux options pour vous dépanner ci dessous:

1° votre colonne de référence n'a pas de trou et vous cherchez la dernière valeur entrée:

Utilisez une colonne hors champs , admettons la colonne X.Nous supposons que vos valeurs à détecter sont dans la colonne A
En B1:
=SOMME(X:X)
En X1
:SI(A2=0;A1;0)
Tirez cette formule sur la hauteur du champ, ainsi B1 vous renverra la dernière valeur de la colonne , (où la somme de celle qui précéde des trous dans la colonne!!!!)
___________________________________________
2° votre colonne a des cellules vides avant la derniére:

Il faut admettre ici que la colonne A a ses limites, admettons pour l'exemple: A1 à 1000 (à vous de réaligner!)
Dans la colonne X en X1 rentrez la formule
=SI(ESTNUM(A2);0;A1)*SI(SOMME(A2:$A$1000)=0;1;0)
Ainsi vous n'aurez en B1 que le renvoi de la cellule qui n'a pas de "suite" dans la colonne A
Attention au blocage de la deuxième partie de la formule, la cellule A2 doit rester évolutive qunad vous la tirez sur la hauteur du champ
Bien entendu, vous pouvez placer cette formulation dans une colonne masquée, voire sur une feuille masquée pour ne pas perturber vos mises en page
Bien cordialement

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

re,

Merci Vaucluse, je suis tout colorindex=3 ...

mais je me suis planté!!!

au lieu de:
=recherchev(car(255);A:A;1)
il faudrait écrire
=rechercheV("zzzzzzzzzzzz";A:A;1)

Bon dimanche
Michel

Reply
réponses:
  • Vaucluse

    Pas de problème, je n'ai traité que la valeur numérique, dans mon essai....!!!!!!
    Errare humanum est, comme disaient de vieux copains à moi, et au moins, cela confirme le bien fondé de ma signature!
    Bien cordialement

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Ah bon ? Pas dans mes tests !
Bye.

Reply
réponses:

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Suis en plein boulot (Merise, Mcd....SQL) sponsorisé par Doliprane

Je mettrai un mot ce soir at home si je suis pas trop crevé; j'aurais du faire jardinier!

Amicalement
Michel

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Re,

Ci joint petite démo sur le problème d'Eric, sans réponse à nos propositions, mais peut-être parti rejoindre Raymond aux antilles pour mieux étudier une solution

http://cjoint.com/?czsZZ1UYlp

Bonsoir ou bonjour

Michel

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

re,re

après la soupe...

Bon sang, mais c'est bien sûr!!!

Formule matricielle (à valider pat Ctrl+maj+entrée)

=INDEX(plage;MAX(SI(plage<>"";LIGNE(plage)))-1)

plage est ici B2:Bx...

A+
Michel

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Merci beaucoup! ça fonctionne bien!

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Si je ne me trompe, cela ne marche que si la colonne A est triée ? La formule renvoie en effet la valeur la plus grande de la liste, pas la dernière !
Amitiés.

Reply
réponses:
  • Vaucluse

    Salut Raymond
    Doit avoir erreur, là.......
    Chez moi, cela marche avec la dernière valeur quelque soit celles entrées dans la colonne, et qu'il y ai des vides ou non dans la liste!
    Bien cordialement

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Dans Libre office cela marche avec:
=RECHERCHE("z";A1:A4999)

"z" : indique dernière valeur
A1:A4999 : de la cellule A1 à la cellule A4999
c'est un exemple, au lieu de A4999 ce peut être A6500 ou peut-être plus

idem pour une ligne, en remplaçant A1:A4999 par A8:ZZ8 (par exemple)

Ne pas mettre la formule à la fin de la colonne ou de la ligne de la recherche

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed